aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/CMakeLists.txt
diff options
context:
space:
mode:
authorJethro Grassie <jtg@xtrabass.com>2018-11-20 13:18:08 -0500
committerJethro Grassie <jtg@xtrabass.com>2018-11-21 12:56:34 -0500
commit517f25efd1d8cc6f10f777b6f8ddd79a088fae4b (patch)
treeee28b49f01396e7559ebf1c88f1d81e70773e3b1 /src/rpc/CMakeLists.txt
parentMerge pull request #4781 (diff)
downloadmonero-517f25efd1d8cc6f10f777b6f8ddd79a088fae4b.tar.xz
rpc: add version to get_info
Diffstat (limited to 'src/rpc/CMakeLists.txt')
-rw-r--r--src/rpc/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/rpc/CMakeLists.txt b/src/rpc/CMakeLists.txt
index 8fc42b7e3..d2c4a33cb 100644
--- a/src/rpc/CMakeLists.txt
+++ b/src/rpc/CMakeLists.txt
@@ -112,6 +112,7 @@ target_link_libraries(rpc
common
cryptonote_core
cryptonote_protocol
+ version
${Boost_REGEX_LIBRARY}
${Boost_THREAD_LIBRARY}
PRIVATE
@@ -121,6 +122,7 @@ target_link_libraries(daemon_messages
LINK_PRIVATE
cryptonote_core
cryptonote_protocol
+ version
serialization
${EXTRA_LIBRARIES})
@@ -129,6 +131,7 @@ target_link_libraries(daemon_rpc_server
rpc
cryptonote_core
cryptonote_protocol
+ version
daemon_messages
serialization
${Boost_CHRONO_LIBRARY}