aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2018-01-10 11:50:58 +0100
committerRiccardo Spagni <ric@spagni.net>2018-01-10 11:50:58 +0100
commitab8a32429a2394e183d3d999859017c51cc0b469 (patch)
tree6a0d636d4cddcf254e98aa55d72c26e8bbf8ec65 /src/rpc/CMakeLists.txt
parentMerge pull request #2983 (diff)
parentfix some link errors in debug mode for macos (diff)
downloadmonero-ab8a32429a2394e183d3d999859017c51cc0b469.tar.xz
Merge pull request #2985
6d8b29ef fix some link errors in debug mode for macos (stoffu) fdd4c5e5 move memwipe to epee to avoid common<->crypto circular dependencies (moneromooo-monero) 40ab12a7 epee: remove dependency on common (moneromooo-monero)
Diffstat (limited to 'src/rpc/CMakeLists.txt')
-rw-r--r--src/rpc/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/rpc/CMakeLists.txt b/src/rpc/CMakeLists.txt
index 748c6b8c1..19ea93902 100644
--- a/src/rpc/CMakeLists.txt
+++ b/src/rpc/CMakeLists.txt
@@ -101,6 +101,7 @@ target_link_libraries(rpc_base
epee
${Boost_REGEX_LIBRARY}
${Boost_THREAD_LIBRARY}
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
PRIVATE
${EXTRA_LIBRARIES})
@@ -125,6 +126,7 @@ target_link_libraries(daemon_messages
target_link_libraries(daemon_rpc_server
LINK_PRIVATE
+ rpc
cryptonote_core
cryptonote_protocol
daemon_messages