aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2016-09-18 11:44:08 +0200
committerRiccardo Spagni <ric@spagni.net>2016-09-18 11:44:08 +0200
commit4a03a8a1da1341fcceeb8a73a24ea1b4cedb443c (patch)
treeae9b02dcb8c241b719e0f8ea7c4ef3fe991b9f3a /src/rpc/CMakeLists.txt
parentMerge pull request #1093 (diff)
parentcmake: support BUILD_SHARED_LIBS built-in option (diff)
downloadmonero-4a03a8a1da1341fcceeb8a73a24ea1b4cedb443c.tar.xz
Merge pull request #1094
06bb692 cmake: support BUILD_SHARED_LIBS built-in option (redfish) e1c7af3 cmake: transitive deps and remove deprecated LINK_* (redfish) 54010b9 crypto: armv7: slow-hash: remove redundant source include (redfish)
Diffstat (limited to 'src/rpc/CMakeLists.txt')
-rw-r--r--src/rpc/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/rpc/CMakeLists.txt b/src/rpc/CMakeLists.txt
index 6e90d1a91..1716da75b 100644
--- a/src/rpc/CMakeLists.txt
+++ b/src/rpc/CMakeLists.txt
@@ -43,13 +43,11 @@ bitmonero_add_library(rpc
${rpc_headers}
${rpc_private_headers})
target_link_libraries(rpc
- LINK_PRIVATE
+ PUBLIC
cryptonote_core
cryptonote_protocol
- ${Boost_CHRONO_LIBRARY}
- ${Boost_REGEX_LIBRARY}
- ${Boost_SYSTEM_LIBRARY}
${Boost_THREAD_LIBRARY}
+ PRIVATE
${EXTRA_LIBRARIES})
add_dependencies(rpc
version)