aboutsummaryrefslogtreecommitdiff
path: root/src/rpc/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 11:24:14 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commit55ca7d3b34762d9184090d659189959261bcb9a1 (patch)
treebb43a29d200f1414e46d6a8e07c8cf12069b6067 /src/rpc/CMakeLists.txt
parentcmake: refactor common code with executables (diff)
downloadmonero-55ca7d3b34762d9184090d659189959261bcb9a1.tar.xz
cmake: refactor common code with libraries
Diffstat (limited to '')
-rw-r--r--src/rpc/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/src/rpc/CMakeLists.txt b/src/rpc/CMakeLists.txt
index 552655dc4..31efe7d4c 100644
--- a/src/rpc/CMakeLists.txt
+++ b/src/rpc/CMakeLists.txt
@@ -34,12 +34,7 @@ set(rpc_headers
core_rpc_server_commands_defs.h
core_rpc_server_error_codes.h)
-source_group(rpc
- FILES
- ${rpc_sources}
- ${rpc_headers})
-
-add_library(rpc
+bitmonero_add_library(rpc
${rpc_sources}
${rpc_headers})
target_link_libraries(rpc
@@ -52,6 +47,3 @@ target_link_libraries(rpc
${EXTRA_LIBRARIES})
add_dependencies(rpc
version)
-set_property(TARGET rpc
- PROPERTY
- FOLDER "libs")