aboutsummaryrefslogtreecommitdiff
path: root/src/net/CMakeLists.txt
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-05-03 00:48:24 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-05-03 01:39:46 +0100
commiteb8c550cbc9fe4abfb3002d81f07be6dfbabc5a4 (patch)
tree73990f8934ace74060c192bf817474e701aebeb1 /src/net/CMakeLists.txt
parenthttps://sourceware.org/bugzilla/show_bug.cgi?id=25210 (diff)
downloadmonero-eb8c550cbc9fe4abfb3002d81f07be6dfbabc5a4.tar.xz
build: rely on pkg-config to find zmq and sodiumv0.15.0.5
if zmq was built with libnorm, libproto or libpgm, pkg-config can inform us directly instead of having to find them. The location of zmq.h can be obtained the same way motivation is to remove opengpm from the list of mandatory dependencies when monero does not have direct dependency on opengpm, but only when zeromq is buily with pgm support which itself has hard dependency on pyton2 which is now EOL.
Diffstat (limited to '')
-rw-r--r--src/net/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/net/CMakeLists.txt b/src/net/CMakeLists.txt
index 1ce7118ad..7a87f4d3d 100644
--- a/src/net/CMakeLists.txt
+++ b/src/net/CMakeLists.txt
@@ -32,5 +32,5 @@ set(net_headers dandelionpp.h error.h i2p_address.h parse.h socks.h socks_connec
tor_address.h zmq.h)
monero_add_library(net ${net_sources} ${net_headers})
-target_link_libraries(net common epee ${ZMQ_LIB} ${Boost_ASIO_LIBRARY})
+target_link_libraries(net common epee ${ZMQ_LIBRARIES} ${Boost_ASIO_LIBRARY})