aboutsummaryrefslogtreecommitdiff
path: root/src/multisig/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-09-26 23:16:25 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-17 16:12:15 +0000
commit66e34e85b1ef3e49ea9290bd69cce2974840fc32 (patch)
tree618a7336e476189da36fb62f0df06e0fdb7b3809 /src/multisig/CMakeLists.txt
parentN-1/N multisig (diff)
downloadmonero-66e34e85b1ef3e49ea9290bd69cce2974840fc32.tar.xz
add multisig core test and factor multisig building blocks
Diffstat (limited to 'src/multisig/CMakeLists.txt')
-rw-r--r--src/multisig/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/multisig/CMakeLists.txt b/src/multisig/CMakeLists.txt
new file mode 100644
index 000000000..432865ad3
--- /dev/null
+++ b/src/multisig/CMakeLists.txt
@@ -0,0 +1,52 @@
+# Copyright (c) 2017, The Monero Project
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification, are
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this list of
+# conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice, this list
+# of conditions and the following disclaimer in the documentation and/or other
+# materials provided with the distribution.
+#
+# 3. Neither the name of the copyright holder nor the names of its contributors may be
+# used to endorse or promote products derived from this software without specific
+# prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set(multisig_sources
+ multisig.cpp)
+
+set(multisig_headers)
+
+set(multisig_private_headers
+ multisig.h)
+
+monero_private_headers(multisig
+ ${multisig_private_headers})
+
+monero_add_library(multisig
+ ${multisig_sources}
+ ${multisig_headers}
+ ${multisig_private_headers})
+
+target_link_libraries(multisig
+ PUBLIC
+ ringct
+ cryptonote_basic
+ common
+ cncrypto
+ PRIVATE
+ ${EXTRA_LIBRARIES})