aboutsummaryrefslogtreecommitdiff
path: root/src/debug_utilities/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-08-03 17:02:13 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-08-04 14:45:38 +0100
commit55e150ff8a420fc8d9aea65be32e6faa048a6dc6 (patch)
tree9d90efacbe8f896473af36dca48e1cd3c6b7ae61 /src/debug_utilities/CMakeLists.txt
parentcn_deserialize: move to new debug_utilities subdirectory (diff)
downloadmonero-55e150ff8a420fc8d9aea65be32e6faa048a6dc6.tar.xz
debug_utilities: new object-sizes debug tool
It prints the size of various interesting types, to make it easier to match leaks to possible leaked object types
Diffstat (limited to 'src/debug_utilities/CMakeLists.txt')
-rw-r--r--src/debug_utilities/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/debug_utilities/CMakeLists.txt b/src/debug_utilities/CMakeLists.txt
index 233e6fd46..99198dc57 100644
--- a/src/debug_utilities/CMakeLists.txt
+++ b/src/debug_utilities/CMakeLists.txt
@@ -48,3 +48,26 @@ set_property(TARGET cn_deserialize
PROPERTY
OUTPUT_NAME "monero-utils-deserialize")
+
+set(object_sizes_sources
+ object_sizes.cpp
+ )
+
+monero_add_executable(object_sizes
+ ${object_sizes_sources}
+ ${object_sizes_private_headers})
+
+target_link_libraries(object_sizes
+ LINK_PRIVATE
+ cryptonote_core
+ blockchain_db
+ p2p
+ epee
+ ${CMAKE_THREAD_LIBS_INIT})
+
+add_dependencies(object_sizes
+ version)
+set_property(TARGET object_sizes
+ PROPERTY
+ OUTPUT_NAME "monero-utils-object-sizes")
+