aboutsummaryrefslogtreecommitdiff
path: root/src/debug_utilities/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-04-16 12:46:01 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2019-04-23 15:20:45 +0000
commit6aa3c2f30353af41854c15186c811fadac229bed (patch)
tree50aaeb72c176df2a5ac0aeec87db47e9e08014d4 /src/debug_utilities/CMakeLists.txt
parentMerge pull request #5440 (diff)
downloadmonero-6aa3c2f30353af41854c15186c811fadac229bed.tar.xz
dns_checks: new helper program to check on DNSSEC lookups
Diffstat (limited to '')
-rw-r--r--src/debug_utilities/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/debug_utilities/CMakeLists.txt b/src/debug_utilities/CMakeLists.txt
index 7bc2c324f..03c2b3e20 100644
--- a/src/debug_utilities/CMakeLists.txt
+++ b/src/debug_utilities/CMakeLists.txt
@@ -69,3 +69,25 @@ set_property(TARGET object_sizes
PROPERTY
OUTPUT_NAME "monero-utils-object-sizes")
+
+set(dns_checks_sources
+ dns_checks.cpp
+ )
+
+monero_add_executable(dns_checks
+ ${dns_checks_sources}
+ ${dns_checks_private_headers})
+
+target_link_libraries(dns_checks
+ LINK_PRIVATE
+ common
+ epee
+ version
+ ${Boost_PROGRAM_OPTIONS_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT})
+
+set_property(TARGET dns_checks
+ PROPERTY
+ OUTPUT_NAME "monero-utils-dns-checks")
+