aboutsummaryrefslogtreecommitdiff
path: root/src/daemonizer/CMakeLists.txt
diff options
context:
space:
mode:
authorston1th <ston1th@giftfish.de>2018-02-13 19:54:49 +0100
committerston1th <ston1th@giftfish.de>2018-02-23 21:27:14 +0100
commit496055d12871eca27b024fd2f746a8e5d07e5714 (patch)
treec8aee88e652efacb042da04d5cb19d145379915a /src/daemonizer/CMakeLists.txt
parentMerge pull request #3198 (diff)
downloadmonero-496055d12871eca27b024fd2f746a8e5d07e5714.tar.xz
monerod: do not log to tmpdir in daemon mode
The logging to /tmp/bitmonero.daemon.stdout.stderr caused segfaults if the /tmp mount was full (#2851). Now the daemon is only logging to /tmp/bitmonero.daemon.stdout.stderr in the debug builds.
Diffstat (limited to 'src/daemonizer/CMakeLists.txt')
-rw-r--r--src/daemonizer/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/daemonizer/CMakeLists.txt b/src/daemonizer/CMakeLists.txt
index 2c0583c49..2753d0003 100644
--- a/src/daemonizer/CMakeLists.txt
+++ b/src/daemonizer/CMakeLists.txt
@@ -54,6 +54,10 @@ else()
)
endif()
+if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+ add_definitions(-DDEBUG_TMPDIR_LOG=1)
+endif()
+
monero_private_headers(daemonizer
${daemonizer_private_headers})
monero_add_library(daemonizer