aboutsummaryrefslogtreecommitdiff
path: root/src/daemonizer/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2018-03-05 19:10:51 +0200
committerRiccardo Spagni <ric@spagni.net>2018-03-05 19:10:51 +0200
commitb54587d7b39f57e81af2184db8c63b3549bea8e9 (patch)
tree3a7e6ea5299c48aadc43479e7b6ca2d2a349f07d /src/daemonizer/CMakeLists.txt
parentMerge pull request #3156 (diff)
parentremoved systemd private tempdir (diff)
downloadmonero-b54587d7b39f57e81af2184db8c63b3549bea8e9.tar.xz
Merge pull request #3259
6d900a40 removed systemd private tempdir (ston1th) 496055d1 monerod: do not log to tmpdir in daemon mode (ston1th)
Diffstat (limited to 'src/daemonizer/CMakeLists.txt')
-rw-r--r--src/daemonizer/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/daemonizer/CMakeLists.txt b/src/daemonizer/CMakeLists.txt
index 2c0583c49..2753d0003 100644
--- a/src/daemonizer/CMakeLists.txt
+++ b/src/daemonizer/CMakeLists.txt
@@ -54,6 +54,10 @@ else()
)
endif()
+if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+ add_definitions(-DDEBUG_TMPDIR_LOG=1)
+endif()
+
monero_private_headers(daemonizer
${daemonizer_private_headers})
monero_add_library(daemonizer