aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-01-29 17:10:53 -0500
committerThomas Winget <tewinget@gmail.com>2015-02-24 00:05:19 -0500
commit9193d6fb5be92df732af18b08b1e052f84cc2f9d (patch)
treedfe58f501122beec786322d30d04efacf8c90259 /src/daemon/CMakeLists.txt
parentMerge pull request #221 (diff)
downloadmonero-9193d6fb5be92df732af18b08b1e052f84cc2f9d.tar.xz
Daemonize changes pulled in -- daemon builds
many RPC functions added by the daemonize changes (and related changes on the upstream dev branch that were not merged) were commented out (apart from return). Other than that, this *should* work...at any rate, it builds, and that's something.
Diffstat (limited to 'src/daemon/CMakeLists.txt')
-rw-r--r--src/daemon/CMakeLists.txt18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/daemon/CMakeLists.txt b/src/daemon/CMakeLists.txt
index 5f60857d6..4de8b82b8 100644
--- a/src/daemon/CMakeLists.txt
+++ b/src/daemon/CMakeLists.txt
@@ -27,12 +27,27 @@
# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
set(daemon_sources
- daemon.cpp)
+ command_parser_executor.cpp
+ command_server.cpp
+ daemon.cpp
+ executor.cpp
+ main.cpp
+ rpc_command_executor.cpp
+)
set(daemon_headers)
set(daemon_private_headers
+ command_parser_executor.h
+ command_server.h
+ core.h
+ daemon.h
daemon_commands_handler.h
+ executor.h
+ p2p.h
+ protocol.h
+ rpc.h
+ rpc_command_executor.h
# cryptonote_protocol
../cryptonote_protocol/blobdatatype.h
@@ -62,6 +77,7 @@ target_link_libraries(daemon
cryptonote_core
crypto
common
+ daemonizer
${Boost_CHRONO_LIBRARY}
${Boost_FILESYSTEM_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY}