aboutsummaryrefslogtreecommitdiff
path: root/src/cryptonote_basic/CMakeLists.txt
diff options
context:
space:
mode:
authorkenshi84 <kenshi84@protonmail.ch>2017-03-10 10:20:38 +0900
committerkenshi84 <kenshi84@protonmail.ch>2017-03-10 11:22:39 +0900
commit7d07c64fe59846b20b1e322881c1ead2fe78460d (patch)
treed8e49fa7cc68b84e46b59c203fcbedbf9e95a3cd /src/cryptonote_basic/CMakeLists.txt
parentMerge pull request #1852 (diff)
downloadmonero-7d07c64fe59846b20b1e322881c1ead2fe78460d.tar.xz
fix dependency: put HardFork back to cryptonote_basic, made some BlockchainDB functions virtual again to avoid missing symbols error
Diffstat (limited to 'src/cryptonote_basic/CMakeLists.txt')
-rw-r--r--src/cryptonote_basic/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/cryptonote_basic/CMakeLists.txt b/src/cryptonote_basic/CMakeLists.txt
index db478c690..2b8ad365a 100644
--- a/src/cryptonote_basic/CMakeLists.txt
+++ b/src/cryptonote_basic/CMakeLists.txt
@@ -32,6 +32,7 @@ set(cryptonote_basic_sources
cryptonote_basic_impl.cpp
cryptonote_format_utils.cpp
difficulty.cpp
+ hardfork.cpp
miner.cpp)
set(cryptonote_basic_headers)
@@ -47,6 +48,7 @@ set(cryptonote_basic_private_headers
cryptonote_format_utils.h
cryptonote_stat_info.h
difficulty.h
+ hardfork.h
miner.h
tx_extra.h
verification_context.h)