aboutsummaryrefslogtreecommitdiff
path: root/src/cryptonote_basic/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2017-09-25 22:27:43 +0200
committerRiccardo Spagni <ric@spagni.net>2017-09-25 22:27:44 +0200
commit29d601563fff1a23fa5c21de8c455d542b1adfe3 (patch)
tree4a071ec0ef979f020a2cf567973e02087494e8b9 /src/cryptonote_basic/CMakeLists.txt
parentMerge pull request #2466 (diff)
parentwallet2: do not keep block hashes below last checkpoint (diff)
downloadmonero-29d601563fff1a23fa5c21de8c455d542b1adfe3.tar.xz
Merge pull request #2434
36c3465b wallet2: do not keep block hashes below last checkpoint (moneromooo-monero) cdbbe99c checkpoints: add a token checkpoint on testnet (the genesis block) (moneromooo-monero) 493fad80 serialization: add deque serialization (moneromooo-monero) fa54b205 fix typo in basic and core CMakeLists.txt (moneromooo-monero) 5d65a75b move checkpoints in a separate library (moneromooo-monero)
Diffstat (limited to 'src/cryptonote_basic/CMakeLists.txt')
-rw-r--r--src/cryptonote_basic/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/cryptonote_basic/CMakeLists.txt b/src/cryptonote_basic/CMakeLists.txt
index 1503b277e..750be69f1 100644
--- a/src/cryptonote_basic/CMakeLists.txt
+++ b/src/cryptonote_basic/CMakeLists.txt
@@ -34,7 +34,6 @@ endif()
set(cryptonote_basic_sources
account.cpp
- checkpoints.cpp
cryptonote_basic_impl.cpp
cryptonote_format_utils.cpp
difficulty.cpp
@@ -46,7 +45,6 @@ set(cryptonote_basic_headers)
set(cryptonote_basic_private_headers
account.h
account_boost_serialization.h
- checkpoints.h
connection_context.h
cryptonote_basic.h
cryptonote_basic_impl.h
@@ -60,7 +58,7 @@ set(cryptonote_basic_private_headers
verification_context.h)
monero_private_headers(cryptonote_basic
- ${crypto_private_headers})
+ ${cryptonote_basic_private_headers})
monero_add_library(cryptonote_basic
${cryptonote_basic_sources}
${cryptonote_basic_headers}
@@ -69,6 +67,7 @@ target_link_libraries(cryptonote_basic
PUBLIC
common
cncrypto
+ checkpoints
${Boost_DATE_TIME_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY}
${Boost_SERIALIZATION_LIBRARY}