aboutsummaryrefslogtreecommitdiff
path: root/src/cryptonote_basic/CMakeLists.txt
diff options
context:
space:
mode:
authorjethro <jtg@xtrabass.com>2017-05-28 13:10:04 -0400
committerjethro <jtg@xtrabass.com>2017-06-08 09:26:09 -0400
commit1b75ad91aafc217f4b83926daa3197f2d86b2e57 (patch)
tree7316d8b1fa421450de3b5b2f8d71faaeab18ef70 /src/cryptonote_basic/CMakeLists.txt
parentMerge pull request #2059 (diff)
downloadmonero-1b75ad91aafc217f4b83926daa3197f2d86b2e57.tar.xz
Add OSX background mining
Implements miner::get_system_times, miner::get_process_time and miner::on_battery_power for OSX so that background mining works on OSX.
Diffstat (limited to '')
-rw-r--r--src/cryptonote_basic/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/cryptonote_basic/CMakeLists.txt b/src/cryptonote_basic/CMakeLists.txt
index ec7aa251f..1503b277e 100644
--- a/src/cryptonote_basic/CMakeLists.txt
+++ b/src/cryptonote_basic/CMakeLists.txt
@@ -26,6 +26,12 @@
# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+if(APPLE)
+ find_library(IOKIT_LIBRARY IOKit)
+ mark_as_advanced(IOKIT_LIBRARY)
+ list(APPEND EXTRA_LIBRARIES ${IOKIT_LIBRARY})
+endif()
+
set(cryptonote_basic_sources
account.cpp
checkpoints.cpp