aboutsummaryrefslogtreecommitdiff
path: root/src/crypto/CMakeLists.txt
diff options
context:
space:
mode:
authorMoroccanMalinois <MoroccanMalinois@protonmail.com>2017-01-05 01:11:05 +0000
committerMoroccanMalinois <MoroccanMalinois@protonmail.com>2017-01-05 01:11:05 +0000
commit80abc3bc4a73f3ba6ffd40b1a03de0cc4d01e3c9 (patch)
tree5b9f6c810e59d36607590a6e736858a7d7d3bf7f /src/crypto/CMakeLists.txt
parentMerge pull request #1487 (diff)
downloadmonero-80abc3bc4a73f3ba6ffd40b1a03de0cc4d01e3c9.tar.xz
Build wallet with Android NDK
Diffstat (limited to 'src/crypto/CMakeLists.txt')
-rw-r--r--src/crypto/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/crypto/CMakeLists.txt b/src/crypto/CMakeLists.txt
index 9d83caca8..1e037a07d 100644
--- a/src/crypto/CMakeLists.txt
+++ b/src/crypto/CMakeLists.txt
@@ -89,3 +89,14 @@ if (ARM)
PROPERTY COMPILE_DEFINITIONS "NO_OPTIMIZED_MULTIPLY_ON_ARM")
endif()
endif()
+
+# Because of the way Qt works on android with JNI, the code does not live in the main android thread
+# So this code runs with a 1 MB default stack size.
+# This will force the use of the heap for the allocation of the scratchpad
+if (ANDROID)
+ if( BUILD_GUI_DEPS )
+ add_definitions(-DFORCE_USE_HEAP=1)
+ endif()
+endif()
+
+