aboutsummaryrefslogtreecommitdiff
path: root/src/crypto/CMakeLists.txt
diff options
context:
space:
mode:
authorstoffu <stoffu@protonmail.ch>2017-12-21 15:22:25 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-01-10 01:57:56 +0000
commit6d8b29ef2800a36236e4d31521878ef02f3084ab (patch)
treeec8f5219cd25266c5e30898e4b3c1d9427cb629d /src/crypto/CMakeLists.txt
parentmove memwipe to epee to avoid common<->crypto circular dependencies (diff)
downloadmonero-6d8b29ef2800a36236e4d31521878ef02f3084ab.tar.xz
fix some link errors in debug mode for macos
Diffstat (limited to 'src/crypto/CMakeLists.txt')
-rw-r--r--src/crypto/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/crypto/CMakeLists.txt b/src/crypto/CMakeLists.txt
index fd71a87e7..764b30273 100644
--- a/src/crypto/CMakeLists.txt
+++ b/src/crypto/CMakeLists.txt
@@ -76,6 +76,7 @@ monero_add_library(cncrypto
${crypto_private_headers})
target_link_libraries(cncrypto
PUBLIC
+ epee
${Boost_SYSTEM_LIBRARY}
PRIVATE
${EXTRA_LIBRARIES})