aboutsummaryrefslogtreecommitdiff
path: root/src/connectivity_tool/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 11:21:28 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commitc773f465ca7e691b94394d8c7c682c8eb78e5c25 (patch)
tree608ab12a156706ef1c876a33614f3ac6b400d6c3 /src/connectivity_tool/CMakeLists.txt
parentcmake: put each library into its own directory (diff)
downloadmonero-c773f465ca7e691b94394d8c7c682c8eb78e5c25.tar.xz
cmake: refactor common code with executables
Diffstat (limited to 'src/connectivity_tool/CMakeLists.txt')
-rw-r--r--src/connectivity_tool/CMakeLists.txt19
1 files changed, 1 insertions, 18 deletions
diff --git a/src/connectivity_tool/CMakeLists.txt b/src/connectivity_tool/CMakeLists.txt
index 150815a5d..de52b0648 100644
--- a/src/connectivity_tool/CMakeLists.txt
+++ b/src/connectivity_tool/CMakeLists.txt
@@ -31,12 +31,7 @@ set(connectivity_tool_sources
set(connectivity_tool_headers)
-source_group(connectivity-tool
- FILES
- ${connectivity_tool_sources}
- ${connectivity_tool_headers})
-
-add_executable(connectivity_tool
+bitmonero_add_executable(connectivity_tool
${connectivity_tool_sources}
${connectivity_tool_headers})
target_link_libraries(connectivity_tool
@@ -48,15 +43,3 @@ target_link_libraries(connectivity_tool
${Boost_PROGRAM_OPTIONS_LIBRARY}
${Boost_REGEX_LIBRARY}
${Boost_SYSTEM_LIBRARY})
-set_property(TARGET connectivity_tool
- PROPERTY
- FOLDER "prog")
-
-if (STATIC)
- set_property(TARGET connectivity_tool
- PROPERTY
- LINK_SEARCH_START_STATIC 1)
- set_property(TARGET connectivity_tool
- PROPERTY
- LINK_SEARCH_END_STATIC 1)
-endif ()