aboutsummaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorLee Clagett <code@leeclagett.com>2018-09-10 21:25:15 -0400
committerLee Clagett <code@leeclagett.com>2018-09-12 22:44:34 +0000
commit55c7cd14582323b4403bed88bd02e2f62d2a3169 (patch)
tree6680eb713cd4c98925212a0339037f774eb79718 /src/common/CMakeLists.txt
parentMerge pull request #4290 (diff)
downloadmonero-55c7cd14582323b4403bed88bd02e2f62d2a3169.tar.xz
Adding expect<T> - a value-or-error implementation
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index f0df05b0d..606f6fc9a 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -33,6 +33,8 @@ set(common_sources
command_line.cpp
dns_utils.cpp
download.cpp
+ error.cpp
+ expect.cpp
util.cpp
i18n.cpp
password.cpp
@@ -54,6 +56,8 @@ set(common_private_headers
common_fwd.h
dns_utils.h
download.h
+ error.h
+ expect.h
http_connection.h
int-util.h
pod-class.h