aboutsummaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2016-03-28 19:00:18 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2016-04-28 23:34:51 +0100
commite409e59d29cd8f8480947d80582ac8e93b495e22 (patch)
tree8c0dbed81ff56d17e3704e400c463a379aebbec9 /src/common/CMakeLists.txt
parentconnection_basic: avoid gratuitous exception (diff)
downloadmonero-e409e59d29cd8f8480947d80582ac8e93b495e22.tar.xz
Print stack trace on exceptions
if libunwind is found. Useful for debugging logs.
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 2289704e5..9afbe4b82 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -31,7 +31,8 @@ set(common_sources
command_line.cpp
dns_utils.cpp
util.cpp
- i18n.cpp)
+ i18n.cpp
+ stack_trace.cpp)
set(common_headers)
@@ -48,7 +49,8 @@ set(common_private_headers
unordered_containers_boost_serialization.h
util.h
varint.h
- i18n.h)
+ i18n.h
+ stack_trace.h)
bitmonero_private_headers(common
${common_private_headers})
@@ -60,6 +62,7 @@ target_link_libraries(common
LINK_PRIVATE
crypto
${UNBOUND_LIBRARY}
+ ${LIBUNWIND_LIBRARIES}
${Boost_DATE_TIME_LIBRARY}
${Boost_FILESYSTEM_LIBRARY}
${Boost_SYSTEM_LIBRARY}