aboutsummaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-10-13 17:07:56 +0200
committerTheCharlatan <seb.kung@gmail.com>2018-12-04 02:21:06 +0100
commit5a76933903ef2f29532588d359862831a3644128 (patch)
tree88dd643545c7fab6b9bca156dfb9ed8d230db2d0 /src/common/CMakeLists.txt
parentMerge pull request #4781 (diff)
downloadmonero-5a76933903ef2f29532588d359862831a3644128.tar.xz
Add glibc back compat code
To ensure that the binaries compiled by gitian run across many linux distributions, enforce 2.17 as the minimum libc version supported.
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index aed9bfee7..1aaab555d 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -49,6 +49,10 @@ if (STACK_TRACE)
list(APPEND common_sources stack_trace.cpp)
endif()
+if (BACKCOMPAT)
+ list(APPEND common_sources compat/glibc_compat.cpp)
+endif()
+
set(common_headers)
set(common_private_headers