aboutsummaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorredfish <redfish@galactica.pw>2016-07-27 01:02:55 -0400
committerredfish <redfish@galactica.pw>2016-07-27 01:52:33 -0400
commit0f990d018357413d5eab36b361aa9236e6b8795d (patch)
tree1edefa3a7155bfae589e9bd34b9da3e4ddc444f1 /src/common/CMakeLists.txt
parentMerge pull request #928 (diff)
downloadmonero-0f990d018357413d5eab36b361aa9236e6b8795d.tar.xz
cmake,common: flag for stack trace
By default the flag is enabled whenever libunwind is found on the system, with the exception of static build on OSX (for which we can't install the throw hook #932 due to lack of support for --wrap in OSX ld64 linker).
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 9afbe4b82..7a2457c93 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -31,8 +31,11 @@ set(common_sources
command_line.cpp
dns_utils.cpp
util.cpp
- i18n.cpp
- stack_trace.cpp)
+ i18n.cpp)
+
+if (STACK_TRACE)
+ list(APPEND common_sources stack_trace.cpp)
+endif()
set(common_headers)