aboutsummaryrefslogtreecommitdiff
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 12:38:00 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commitf53f04724c714a40c10e8c0afdca465054fabca8 (patch)
tree954045d002843d5a7767b87be199adc9be2f31b6 /src/common/CMakeLists.txt
parentcmake: refactor common code with libraries (diff)
downloadmonero-f53f04724c714a40c10e8c0afdca465054fabca8.tar.xz
cmake: handle private vs. public headers
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 47456afbd..fcc30e192 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -32,7 +32,9 @@ set(common_sources
dns_utils.cpp
util.cpp)
-set(common_headers
+set(common_headers)
+
+set(common_private_headers
base58.h
boost_serialization_helper.h
command_line.h
@@ -43,9 +45,12 @@ set(common_headers
util.h
varint.h)
+bitmonero_private_headers(common
+ ${common_private_headers})
bitmonero_add_library(common
${common_sources}
- ${common_headers})
+ ${common_headers}
+ ${common_private_headers})
target_link_libraries(common
PRIVATE
crypto
@@ -54,3 +59,6 @@ target_link_libraries(common
${Boost_FILESYSTEM_LIBRARY}
${Boost_SYSTEM_LIBRARY}
${EXTRA_LIBRARIES})
+
+#bitmonero_install_headers(common
+# ${common_headers})