aboutsummaryrefslogtreecommitdiff
path: root/src/blockchain_utilities/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-07-16 16:27:52 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-07-30 21:39:18 +0100
commit888324fa57dea0fba1138c4347c31a33b4241090 (patch)
tree673983ed08df93d58c4300dff88c6a8d9db3322b /src/blockchain_utilities/CMakeLists.txt
parentMerge pull request #4129 (diff)
downloadmonero-888324fa57dea0fba1138c4347c31a33b4241090.tar.xz
blockchain_ancestry: finds all ancestors of a tx, block, or chain
Diffstat (limited to 'src/blockchain_utilities/CMakeLists.txt')
-rw-r--r--src/blockchain_utilities/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/blockchain_utilities/CMakeLists.txt b/src/blockchain_utilities/CMakeLists.txt
index 338ec3e4b..0ff768143 100644
--- a/src/blockchain_utilities/CMakeLists.txt
+++ b/src/blockchain_utilities/CMakeLists.txt
@@ -91,6 +91,17 @@ monero_private_headers(blockchain_usage
+set(blockchain_ancestry_sources
+ blockchain_ancestry.cpp
+ )
+
+set(blockchain_ancestry_private_headers)
+
+monero_private_headers(blockchain_ancestry
+ ${blockchain_ancestry_private_headers})
+
+
+
monero_add_executable(blockchain_import
${blockchain_import_sources}
${blockchain_import_private_headers}
@@ -183,3 +194,24 @@ set_property(TARGET blockchain_usage
OUTPUT_NAME "monero-blockchain-usage")
install(TARGETS blockchain_usage DESTINATION bin)
+monero_add_executable(blockchain_ancestry
+ ${blockchain_ancestry_sources}
+ ${blockchain_ancestry_private_headers})
+
+target_link_libraries(blockchain_ancestry
+ PRIVATE
+ cryptonote_core
+ blockchain_db
+ version
+ epee
+ ${Boost_FILESYSTEM_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${Boost_THREAD_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+
+set_property(TARGET blockchain_ancestry
+ PROPERTY
+ OUTPUT_NAME "monero-blockchain-ancestry")
+install(TARGETS blockchain_ancestry DESTINATION bin)
+