aboutsummaryrefslogtreecommitdiff
path: root/src/blockchain_utilities/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-07-10 19:56:05 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-08-07 21:20:49 +0000
commit289880d82d3cb206a2cf4ae67d2deacdab43d4f4 (patch)
treef535dbb4c32fa509cc3f8ce20ebc805ae0a77f20 /src/blockchain_utilities/CMakeLists.txt
parentblockchain_ancestry: faster and uses less memory (diff)
downloadmonero-289880d82d3cb206a2cf4ae67d2deacdab43d4f4.tar.xz
blockchain_depth: get the average min depth of a set of txes
Diffstat (limited to 'src/blockchain_utilities/CMakeLists.txt')
-rw-r--r--src/blockchain_utilities/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/blockchain_utilities/CMakeLists.txt b/src/blockchain_utilities/CMakeLists.txt
index 0ff768143..fe57895e1 100644
--- a/src/blockchain_utilities/CMakeLists.txt
+++ b/src/blockchain_utilities/CMakeLists.txt
@@ -102,6 +102,17 @@ monero_private_headers(blockchain_ancestry
+set(blockchain_depth_sources
+ blockchain_depth.cpp
+ )
+
+set(blockchain_depth_private_headers)
+
+monero_private_headers(blockchain_depth
+ ${blockchain_depth_private_headers})
+
+
+
monero_add_executable(blockchain_import
${blockchain_import_sources}
${blockchain_import_private_headers}
@@ -215,3 +226,24 @@ set_property(TARGET blockchain_ancestry
OUTPUT_NAME "monero-blockchain-ancestry")
install(TARGETS blockchain_ancestry DESTINATION bin)
+monero_add_executable(blockchain_depth
+ ${blockchain_depth_sources}
+ ${blockchain_depth_private_headers})
+
+target_link_libraries(blockchain_depth
+ PRIVATE
+ cryptonote_core
+ blockchain_db
+ version
+ epee
+ ${Boost_FILESYSTEM_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${Boost_THREAD_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+
+set_property(TARGET blockchain_depth
+ PROPERTY
+ OUTPUT_NAME "monero-blockchain-depth")
+install(TARGETS blockchain_depth DESTINATION bin)
+