aboutsummaryrefslogtreecommitdiff
path: root/src/blockchain_utilities/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-02-27 12:54:28 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2018-03-16 10:32:46 +0000
commit0590f62ab64cf023d397b995072035986931a6b4 (patch)
tree24744feb5ea0a51312806934e0811a382515620b /src/blockchain_utilities/CMakeLists.txt
parentwallet: make ringdb an object with database state (diff)
downloadmonero-0590f62ab64cf023d397b995072035986931a6b4.tar.xz
new blockchain_usage tool, reports on output usage
Diffstat (limited to 'src/blockchain_utilities/CMakeLists.txt')
-rw-r--r--src/blockchain_utilities/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/blockchain_utilities/CMakeLists.txt b/src/blockchain_utilities/CMakeLists.txt
index 4b2df46d8..a5dd69556 100644
--- a/src/blockchain_utilities/CMakeLists.txt
+++ b/src/blockchain_utilities/CMakeLists.txt
@@ -80,6 +80,16 @@ set(blockchain_blackball_private_headers
monero_private_headers(blockchain_blackball
${blockchain_blackball_private_headers})
+set(blockchain_usage_sources
+ blockchain_usage.cpp
+ )
+
+set(blockchain_usage_private_headers)
+
+monero_private_headers(blockchain_usage
+ ${blockchain_usage_private_headers})
+
+
monero_add_executable(blockchain_import
${blockchain_import_sources}
@@ -154,3 +164,26 @@ set_property(TARGET blockchain_blackball
OUTPUT_NAME "monero-blockchain-blackball")
install(TARGETS blockchain_blackball DESTINATION bin)
+
+monero_add_executable(blockchain_usage
+ ${blockchain_usage_sources}
+ ${blockchain_usage_private_headers})
+
+target_link_libraries(blockchain_usage
+ PRIVATE
+ cryptonote_core
+ blockchain_db
+ p2p
+ version
+ epee
+ ${Boost_FILESYSTEM_LIBRARY}
+ ${Boost_SYSTEM_LIBRARY}
+ ${Boost_THREAD_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${EXTRA_LIBRARIES})
+
+set_property(TARGET blockchain_usage
+ PROPERTY
+ OUTPUT_NAME "monero-blockchain-usage")
+install(TARGETS blockchain_usage DESTINATION bin)
+