aboutsummaryrefslogtreecommitdiff
path: root/src/blockchain_db/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-03-16 09:14:51 -0400
committerThomas Winget <tewinget@gmail.com>2015-03-16 09:14:51 -0400
commit43477b7dac861a83ade364ebb5a5c3da8228b3e4 (patch)
tree8ac746edc7275924353fc8ffbe1556d615b2ccfe /src/blockchain_db/CMakeLists.txt
parentCMake wiring, minor cleanup, minor test addition (diff)
downloadmonero-43477b7dac861a83ade364ebb5a5c3da8228b3e4.tar.xz
BerkeleyDB Blockchain building, not working yet
Everything except actually *using* BlockchainBDB is wired up, but the db itself is not yet working. Some error about user mem not large enough. I think I know what this error means, but I can't determine the cause. Notes: BerkeleyDB does not allow 0-indexing in its recno type databases, so block numbers *in the database* will be 1-indexed. Modifications to indexing have been made as needed.
Diffstat (limited to 'src/blockchain_db/CMakeLists.txt')
-rw-r--r--src/blockchain_db/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/blockchain_db/CMakeLists.txt b/src/blockchain_db/CMakeLists.txt
index 62b2eabe2..70b4c876c 100644
--- a/src/blockchain_db/CMakeLists.txt
+++ b/src/blockchain_db/CMakeLists.txt
@@ -54,10 +54,10 @@ target_link_libraries(blockchain_db
${Boost_DATE_TIME_LIBRARY}
${Boost_PROGRAM_OPTIONS_LIBRARY}
${Boost_SERIALIZATION_LIBRARY}
+ ${LMDB_LIBRARY}
+ ${BDB_LIBRARY}
LINK_PRIVATE
${Boost_FILESYSTEM_LIBRARY}
${Boost_SYSTEM_LIBRARY}
${Boost_THREAD_LIBRARY}
- ${LMDB_LIBRARY}
- ${BDB_LIBRARY}
${EXTRA_LIBRARIES})