aboutsummaryrefslogtreecommitdiff
path: root/src/blockchain_converter/CMakeLists.txt
diff options
context:
space:
mode:
authorwarptangent <warptangent@inbox.com>2015-05-08 13:46:26 -0700
committerwarptangent <warptangent@inbox.com>2015-05-08 14:12:20 -0700
commit1eb4c66ad8647c8f73c31dd32645a689426346bd (patch)
tree095e5fd0143a7e2366217e58078bc3a0c215ec69 /src/blockchain_converter/CMakeLists.txt
parentAdd MDB_NORDAHEAD as a supported LMDB flag for blockchain_import (diff)
downloadmonero-1eb4c66ad8647c8f73c31dd32645a689426346bd.tar.xz
Update blockchain utilities with portable bootstrap file format
Remove repeated coinbase tx in each exported block's data. Add resume from last exported height to blockchain_export, making it the default behavior when the file already exists. Start reorganizing the utilities. Various cleanup. Update output, including referring to both height and block numbers as zero-based instead of one-based. This better matches the block data, rather than just some parts of the existing codebase. Use smaller default batch sizes for importer when verifying, so progress is saved more frequently. Use small default batch size (1000) for importer on Windows, due to current issue with big transaction sizes on LMDB. file format ----------- [4-byte magic | variable-length header | block data] header ------ 4-byte file_info length file_info struct file format major version file format minor version header length (includes file_info struct) [rest of header, padded with 0 bytes up to header length] block data ---------- 4-byte chunk/block_package length block_package struct block txs (coinbase/miner tx included already in block) block_size cumulative_difficulty coins_generated 4-byte chunk/block_package length block_package struct [...]
Diffstat (limited to 'src/blockchain_converter/CMakeLists.txt')
-rw-r--r--src/blockchain_converter/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/blockchain_converter/CMakeLists.txt b/src/blockchain_converter/CMakeLists.txt
index 660650980..5be37c450 100644
--- a/src/blockchain_converter/CMakeLists.txt
+++ b/src/blockchain_converter/CMakeLists.txt
@@ -37,11 +37,13 @@ bitmonero_private_headers(blockchain_converter
set(blockchain_import_sources
blockchain_import.cpp
+ bootstrap_file.cpp
)
set(blockchain_import_private_headers
- import.h
fake_core.h
+ bootstrap_file.h
+ bootstrap_serialization.h
)
bitmonero_private_headers(blockchain_import
@@ -49,11 +51,12 @@ bitmonero_private_headers(blockchain_import
set(blockchain_export_sources
blockchain_export.cpp
+ bootstrap_file.cpp
)
set(blockchain_export_private_headers
- import.h
- blockchain_export.h
+ bootstrap_file.h
+ bootstrap_serialization.h
)
bitmonero_private_headers(blockchain_export