aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorstoffu <stoffu@protonmail.ch>2017-09-14 08:28:23 +0900
committerstoffu <stoffu@protonmail.ch>2017-09-21 07:47:37 +0900
commite29282d2081709e126b1fb67f49e9d4a666794da (patch)
tree1787dbfeb55ffaa94a34813cf53c741544d2dd3e /src/CMakeLists.txt
parentMerge pull request #2441 (diff)
downloadmonero-e29282d2081709e126b1fb67f49e9d4a666794da.tar.xz
build: auto update version info without manually deleting version.h
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e3cb7cfd6..3e0bfb59c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -96,6 +96,9 @@ function (monero_add_library name)
PRIVATE $<TARGET_PROPERTY:${name},INTERFACE_COMPILE_DEFINITIONS>)
endfunction ()
+set_source_files_properties(${CMAKE_BINARY_DIR}/version.cpp PROPERTIES GENERATED ON)
+monero_add_library(version ${CMAKE_BINARY_DIR}/version.cpp)
+
add_subdirectory(common)
add_subdirectory(crypto)
add_subdirectory(ringct)