aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 12:38:00 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commitf53f04724c714a40c10e8c0afdca465054fabca8 (patch)
tree954045d002843d5a7767b87be199adc9be2f31b6 /src/CMakeLists.txt
parentcmake: refactor common code with libraries (diff)
downloadmonero-f53f04724c714a40c10e8c0afdca465054fabca8.tar.xz
cmake: handle private vs. public headers
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3a229ddda..ec773ae02 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -32,6 +32,19 @@ add_definitions(-DSTATICLIB)
# miniupnp changed their static define
add_definitions(-DMINIUPNP_STATICLIB)
+function (bitmonero_private_headers group)
+ source_group("${group}\\Private"
+ FILES
+ ${ARGN})
+endfunction ()
+
+function (bitmonero_install_headers subdir)
+ install(
+ FILES ${ARGN}
+ DESTINATION "include/${subdir}"
+ COMPONENT development)
+endfunction ()
+
function (bitmonero_add_executable name)
source_group("${name}"
FILES