aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAntonio Juarez <antonio.maria.juarez@live.com>2014-03-03 22:07:58 +0000
committerAntonio Juarez <antonio.maria.juarez@live.com>2014-03-03 22:07:58 +0000
commit296ae46ed8f8f6e5f986f978febad302e3df231a (patch)
tree1629164454a239308f33c9e12afb22e7f3cd8eeb /src/CMakeLists.txt
parentchanged name (diff)
downloadmonero-296ae46ed8f8f6e5f986f978febad302e3df231a.tar.xz
moved all stuff to github
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 000000000..600413f16
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,44 @@
+file(GLOB_RECURSE COMMON common/*)
+file(GLOB_RECURSE CRYPTO crypto/*)
+file(GLOB_RECURSE CRYPTONOTE_CORE cryptonote_core/*)
+file(GLOB_RECURSE CRYPTONOTE_PROTOCOL cryptonote_protocol/*)
+file(GLOB_RECURSE DAEMON daemon/*)
+file(GLOB_RECURSE P2P p2p/*)
+file(GLOB_RECURSE RPC rpc/*)
+file(GLOB_RECURSE SIMPLEWALLET simplewallet/*)
+file(GLOB_RECURSE CONN_TOOL connectivity_tool/*)
+file(GLOB_RECURSE WALLET wallet/*)
+file(GLOB_RECURSE MINER miner/*)
+
+source_group(common FILES ${COMMON})
+source_group(crypto FILES ${CRYPTO})
+source_group(cryptonote_core FILES ${CRYPTONOTE_CORE})
+source_group(cryptonote_protocol FILES ${CRYPTONOTE_PROTOCOL})
+source_group(daemon FILES ${DAEMON})
+source_group(p2p FILES ${P2P})
+source_group(rpc FILES ${RPC})
+source_group(simplewallet FILES ${SIMPLEWALLET})
+source_group(connectivity-tool FILES ${CONN_TOOL})
+source_group(wallet FILES ${WALLET})
+source_group(simpleminer FILES ${MINER})
+
+add_library(common ${COMMON})
+add_library(crypto ${CRYPTO})
+add_library(cryptonote_core ${CRYPTONOTE_CORE})
+add_executable(daemon ${DAEMON} ${P2P} ${CRYPTONOTE_PROTOCOL})
+add_executable(connectivity_tool ${CONN_TOOL})
+add_executable(simpleminer ${MINER})
+target_link_libraries(daemon rpc cryptonote_core crypto common ${Boost_LIBRARIES})
+target_link_libraries(connectivity_tool cryptonote_core crypto common ${Boost_LIBRARIES})
+target_link_libraries(simpleminer cryptonote_core crypto common ${Boost_LIBRARIES})
+add_dependencies(daemon version)
+add_library(rpc ${RPC})
+add_library(wallet ${WALLET})
+add_executable(simplewallet ${SIMPLEWALLET} )
+target_link_libraries(simplewallet wallet rpc cryptonote_core crypto common ${Boost_LIBRARIES})
+add_dependencies(simplewallet version)
+add_dependencies(daemon version)
+
+set_property(TARGET common crypto cryptonote_core rpc wallet PROPERTY FOLDER "libs")
+set_property(TARGET daemon simplewallet connectivity_tool simpleminer PROPERTY FOLDER "prog")
+set_property(TARGET daemon PROPERTY OUTPUT_NAME "bytecoind")