aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-21 11:24:14 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-23 16:42:34 -0400
commit55ca7d3b34762d9184090d659189959261bcb9a1 (patch)
treebb43a29d200f1414e46d6a8e07c8cf12069b6067 /src/CMakeLists.txt
parentcmake: refactor common code with executables (diff)
downloadmonero-55ca7d3b34762d9184090d659189959261bcb9a1.tar.xz
cmake: refactor common code with libraries
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 868bdc2e9..3a229ddda 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -56,6 +56,18 @@ function (bitmonero_add_executable name)
endif ()
endfunction ()
+function (bitmonero_add_library name)
+ source_group("${name}"
+ FILES
+ ${ARGN})
+
+ add_library("${name}"
+ ${ARGN})
+ set_property(TARGET "${name}"
+ PROPERTY
+ FOLDER "libs")
+endfunction ()
+
add_subdirectory(common)
add_subdirectory(crypto)
add_subdirectory(cryptonote_core)