aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-24 14:48:14 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-24 15:29:51 -0400
commit7d708e422397fb0ba8ac29855eb27964115e7217 (patch)
tree4bc144c393ff8c14d2a6bd443668088f4db5a189 /src/CMakeLists.txt
parentcmake: fix up miniupnpc's define (diff)
downloadmonero-7d708e422397fb0ba8ac29855eb27964115e7217.tar.xz
cmake: support 2.8.7
Older versions of CMake support LINK_{PUBLIC,PRIVATE} while newer versions prefer PUBLIC and PRIVATE instead, but still support the LINK_ prefix.
Diffstat (limited to '')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index dfdf90b97..8cd39a544 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -55,7 +55,7 @@ function (bitmonero_add_executable name)
add_executable("${name}"
${ARGN})
target_link_libraries("${name}"
- PRIVATE
+ LINK_PRIVATE
${EXTRA_LIBRARIES})
set_property(TARGET "${name}"
PROPERTY