aboutsummaryrefslogtreecommitdiff
path: root/external/unbound/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2016-02-13 19:51:56 +0200
committerRiccardo Spagni <ric@spagni.net>2016-02-13 19:51:56 +0200
commit354d47828607d3de103048f5e4143f13f7e14b37 (patch)
tree428aca0d999c95b471ea4c45188528697ddba447 /external/unbound/CMakeLists.txt
parentMerge pull request #652 (diff)
parentcmake: Include OpenSSL libraries in static linking (diff)
downloadmonero-354d47828607d3de103048f5e4143f13f7e14b37.tar.xz
Merge pull request #656
9832d18 cmake: Include OpenSSL libraries in static linking (warptangent) c2f2437 cmake: Remove unused variable (warptangent) 7205210 cmake: Fix unbound config compile settings (warptangent) 3e72d97 cmake: Fix overly broad use of dynamic link settings (warptangent)
Diffstat (limited to 'external/unbound/CMakeLists.txt')
-rw-r--r--external/unbound/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/external/unbound/CMakeLists.txt b/external/unbound/CMakeLists.txt
index 839b21c70..0dd5d6bc4 100644
--- a/external/unbound/CMakeLists.txt
+++ b/external/unbound/CMakeLists.txt
@@ -40,6 +40,12 @@ if (APPLE)
endif()
find_package(OpenSSL REQUIRED)
+if(STATIC)
+ if(UNIX)
+ set(OPENSSL_LIBRARIES "${OPENSSL_LIBRARIES};${CMAKE_DL_LIBS}")
+ endif()
+endif()
+
find_package(Threads)
include(configure_checks.cmake)