aboutsummaryrefslogtreecommitdiff
path: root/external/unbound/CMakeLists.txt
diff options
context:
space:
mode:
authorPavel Maryanov <acid@jack.kiev.ua>2017-10-10 14:05:28 +0100
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-11-14 17:03:48 +0000
commita17efcb039c1128fdb11fd147687f15f2ae12494 (patch)
treea01aa752a2183326286d8b81ec14c4e8697e4ecd /external/unbound/CMakeLists.txt
parentMerge pull request #2756 (diff)
downloadmonero-a17efcb039c1128fdb11fd147687f15f2ae12494.tar.xz
make this build on SunOS/Solaris
Diffstat (limited to 'external/unbound/CMakeLists.txt')
-rw-r--r--external/unbound/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/external/unbound/CMakeLists.txt b/external/unbound/CMakeLists.txt
index 8ac4bbd84..a2e475232 100644
--- a/external/unbound/CMakeLists.txt
+++ b/external/unbound/CMakeLists.txt
@@ -44,7 +44,12 @@ endif ()
set(RETSIGTYPE void)
+if(CMAKE_SYSTEM_NAME MATCHES "(SunOS|Solaris)")
+add_definitions(-D_XOPEN_SOURCE=600)
+else()
add_definitions(-D_GNU_SOURCE)
+endif()
+add_definitions(-std=c99)
option(USE_ECDSA "Use ECDSA algorithms" ON)
option(USE_SHA2 "Enable SHA2 support" ON)