aboutsummaryrefslogtreecommitdiff
path: root/external/unbound/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2015-12-31 08:20:22 +0200
committerRiccardo Spagni <ric@spagni.net>2015-12-31 08:20:22 +0200
commit2be1ae39068d5fdc7c76344c2249dffb0c08ea46 (patch)
tree51c95048efa3d7181b1f52f7656da6ee5bc354ff /external/unbound/CMakeLists.txt
parentMerge pull request #580 (diff)
parentisblank doesn't need a special case test (diff)
downloadmonero-2be1ae39068d5fdc7c76344c2249dffb0c08ea46.tar.xz
Merge pull request #581
10ae003 isblank doesn't need a special case test (Howard Chu) a090ee9 Fix 3edbf57b62feeaba1f31683f24b9d76d75e03902 (Howard Chu)
Diffstat (limited to 'external/unbound/CMakeLists.txt')
-rw-r--r--external/unbound/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/external/unbound/CMakeLists.txt b/external/unbound/CMakeLists.txt
index 4edb51230..3a87745be 100644
--- a/external/unbound/CMakeLists.txt
+++ b/external/unbound/CMakeLists.txt
@@ -141,7 +141,7 @@ set(common_src
set(compat_src)
-foreach (symbol IN ITEMS ctime_r gmtime_r inet_aton inet_ntop inet_pton malloc memcmp memmove snprintf strlcat strlcpy strptime explicit_bzero arc4random arc4random_uniform sha512 reallocarray)
+foreach (symbol IN ITEMS ctime_r gmtime_r inet_aton inet_ntop inet_pton isblank malloc memcmp memmove snprintf strlcat strlcpy strptime explicit_bzero arc4random arc4random_uniform sha512 reallocarray)
string(TOUPPER "${symbol}" upper_sym)
if (NOT HAVE_${upper_sym})
list(APPEND compat_src
@@ -168,11 +168,6 @@ elseif (WIN32)
compat/getentropy_win.c)
endif ()
-if (NOT HAVE_ISBLANK)
- list(APPEND compat_src
- compat/isblank.c)
-endif ()
-
if (NOT HAVE_GETADDRINFO)
list(APPEND compat_src
compat/fake-rfc2553.c)