aboutsummaryrefslogtreecommitdiff
path: root/external/miniupnpc/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2014-10-02 18:43:13 +0200
committerRiccardo Spagni <ric@spagni.net>2014-10-02 18:54:55 +0200
commit18281f4d205d9e320fad23ac3c28b66ea4bb2ff7 (patch)
treef007a38c98ad2f8d6e7b3cd85230b0ce4c5fcf02 /external/miniupnpc/CMakeLists.txt
parentfixed unbound static lib on mingw as libunbound.dll.a (diff)
downloadmonero-18281f4d205d9e320fad23ac3c28b66ea4bb2ff7.tar.xz
remove dangling upnp port mappings, updated miniupnpc
Diffstat (limited to 'external/miniupnpc/CMakeLists.txt')
-rw-r--r--[-rwxr-xr-x]external/miniupnpc/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/external/miniupnpc/CMakeLists.txt b/external/miniupnpc/CMakeLists.txt
index 74aaa0509..4631725ec 100755..100644
--- a/external/miniupnpc/CMakeLists.txt
+++ b/external/miniupnpc/CMakeLists.txt
@@ -36,7 +36,7 @@ else (NOT WIN32)
endif (NOT WIN32)
if (CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- add_definitions (-DMACOSX -D_DARWIN_C_SOURCE)
+ add_definitions (-D_DARWIN_C_SOURCE)
endif ()
# Set compiler specific build flags
@@ -86,16 +86,14 @@ endif (NOT WIN32 AND NOT CMAKE_SYSTEM_NAME STREQUAL "AmigaOS")
if (WIN32)
set_source_files_properties (${MINIUPNPC_SOURCES} PROPERTIES
- COMPILE_DEFINITIONS STATICLIB
+ COMPILE_DEFINITIONS MINIUPNP_STATICLIB
COMPILE_DEFINITIONS MINIUPNP_EXPORTS
)
endif (WIN32)
if (WIN32)
-# find_library (WINSOCK2_LIBRARY NAMES ws2_32 WS2_32 Ws2_32)
-# find_library (IPHLPAPI_LIBRARY NAMES iphlpapi)
- set(WINSOCK2_LIBRARY ws2_32)
- set(IPHLPAPI_LIBRARY iphlpapi)
+ find_library (WINSOCK2_LIBRARY NAMES ws2_32 WS2_32 Ws2_32)
+ find_library (IPHLPAPI_LIBRARY NAMES iphlpapi)
set (LDLIBS ${WINSOCK2_LIBRARY} ${IPHLPAPI_LIBRARY} ${LDLIBS})
#elseif (CMAKE_SYSTEM_NAME STREQUAL "Solaris")
# find_library (SOCKET_LIBRARY NAMES socket)
@@ -167,6 +165,8 @@ install (FILES
igd_desc_parse.h
upnpreplyparse.h
upnperrors.h
+ miniupnpctypes.h
+ portlistingparse.h
declspec.h
DESTINATION include/miniupnpc
)