aboutsummaryrefslogtreecommitdiff
path: root/external/miniupnpc/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2016-03-21 22:49:05 +0200
committerRiccardo Spagni <ric@spagni.net>2016-03-21 22:49:06 +0200
commit8146497f4c0689712f2de1d49c45afea528ef735 (patch)
treecc4f9cee6bb2b040b6ada519a1641c1975c6e5e3 /external/miniupnpc/CMakeLists.txt
parentMerge pull request #743 (diff)
parentfix building on FreeBSD (diff)
downloadmonero-8146497f4c0689712f2de1d49c45afea528ef735.tar.xz
Merge pull request #744
40974b1 fix building on FreeBSD (Riccardo Spagni) 1800d61 bump miniupnpc API version number (Riccardo Spagni) a4242c4 update miniupnpc (Riccardo Spagni)
Diffstat (limited to 'external/miniupnpc/CMakeLists.txt')
-rw-r--r--external/miniupnpc/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/external/miniupnpc/CMakeLists.txt b/external/miniupnpc/CMakeLists.txt
index 1e7645a9d..fd75f9ff5 100644
--- a/external/miniupnpc/CMakeLists.txt
+++ b/external/miniupnpc/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required (VERSION 2.6)
project (miniupnpc C)
set (MINIUPNPC_VERSION 1.9)
-set (MINIUPNPC_API_VERSION 15)
+set (MINIUPNPC_API_VERSION 16)
# - we comment out this block as we don't support these other build types
if(0)
@@ -33,7 +33,7 @@ endif (NO_GETADDRINFO)
if (NOT WIN32)
add_definitions (-DMINIUPNPC_SET_SOCKET_TIMEOUT)
- add_definitions (-D_BSD_SOURCE -D_DEFAULT_SOURCE -D_POSIX_C_SOURCE=200112L)
+ add_definitions (-D_BSD_SOURCE -D_DEFAULT_SOURCE)
else (NOT WIN32)
add_definitions (-D_WIN32_WINNT=0x0501) # XP or higher for getnameinfo and friends
endif (NOT WIN32)