aboutsummaryrefslogtreecommitdiff
path: root/external/easylogging++/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2018-01-10 11:53:26 +0100
committerRiccardo Spagni <ric@spagni.net>2018-01-10 11:53:26 +0100
commitd08aee7a7eae23aaf35c1f129faa5a70d2f5510f (patch)
tree900362d33e020797fa6b2b7bafc87e9a39172b10 /external/easylogging++/CMakeLists.txt
parentMerge pull request #2990 (diff)
parentAdd misc hardening flags to the cmake machinery (diff)
downloadmonero-d08aee7a7eae23aaf35c1f129faa5a70d2f5510f.tar.xz
Merge pull request #2993
776b44f1 Add misc hardening flags to the cmake machinery (moneromooo-monero)
Diffstat (limited to 'external/easylogging++/CMakeLists.txt')
-rw-r--r--external/easylogging++/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/external/easylogging++/CMakeLists.txt b/external/easylogging++/CMakeLists.txt
index 97d0bf571..8fe3fa487 100644
--- a/external/easylogging++/CMakeLists.txt
+++ b/external/easylogging++/CMakeLists.txt
@@ -54,4 +54,5 @@ if (BUILD_GUI_DEPS)
ARCHIVE DESTINATION ${lib_folder}
LIBRARY DESTINATION ${lib_folder})
endif()
+set_property(TARGET easylogging APPEND PROPERTY COMPILE_FLAGS "-fPIC")