aboutsummaryrefslogtreecommitdiff
path: root/external/db_drivers/liblmdb/CMakeLists.txt
diff options
context:
space:
mode:
authorHoward Chu <hyc@symas.com>2015-12-20 16:27:42 +0000
committerHoward Chu <hyc@symas.com>2015-12-25 08:56:03 +0000
commitba4e217c907d6750aa9ca6cb8b1cb099c8a29523 (patch)
tree7bbd1cf03ebd143696ea919a1dadfe9405ff603e /external/db_drivers/liblmdb/CMakeLists.txt
parentMerge pull request #560 (diff)
downloadmonero-ba4e217c907d6750aa9ca6cb8b1cb099c8a29523.tar.xz
Update liblmdb, unify 32/64 sources
Diffstat (limited to '')
-rw-r--r--external/db_drivers/liblmdb/CMakeLists.txt (renamed from external/db_drivers/liblmdb32/CMakeLists.txt)13
1 files changed, 9 insertions, 4 deletions
diff --git a/external/db_drivers/liblmdb32/CMakeLists.txt b/external/db_drivers/liblmdb/CMakeLists.txt
index 293da1039..d951c83c5 100644
--- a/external/db_drivers/liblmdb32/CMakeLists.txt
+++ b/external/db_drivers/liblmdb/CMakeLists.txt
@@ -27,12 +27,9 @@
# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
if(FREEBSD)
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DMDB_DSYNC=O_SYNC")
+ add_definitions(-DMDB_DSYNC=O_SYNC)
endif()
-# pass the VL32 flag so that we actually invoke the VL32 extensions
-set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DVL32")
-
set (lmdb_sources
mdb.c
midl.c)
@@ -44,3 +41,11 @@ add_library(lmdb
target_link_libraries(lmdb
LINK_PRIVATE
${CMAKE_THREAD_LIBS_INIT})
+if(WIN32)
+ target_link_libraries(lmdb
+ -lntdll)
+endif()
+if(${ARCH_WIDTH} EQUAL 32)
+ target_compile_definitions(lmdb
+ PUBLIC -DMDB_VL32)
+endif()