aboutsummaryrefslogtreecommitdiff
path: root/external/db_drivers/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Winget <tewinget@gmail.com>2015-03-17 18:03:11 -0400
committerThomas Winget <tewinget@gmail.com>2015-03-17 18:03:11 -0400
commit11e815761f31b84d96c37cc621c58669ce0c3d1b (patch)
tree6760c2288ed4502c4ceb4034baf7281a7501e076 /external/db_drivers/CMakeLists.txt
parentRevert "Build fixed, goofed up some CMake" (diff)
downloadmonero-11e815761f31b84d96c37cc621c58669ce0c3d1b.tar.xz
Revert "Moved db_drivers/ into external/ for consistency"
This reverts commit b21335642e75b35d3b178a754f4cdb2314989cd1.
Diffstat (limited to 'external/db_drivers/CMakeLists.txt')
-rw-r--r--external/db_drivers/CMakeLists.txt49
1 files changed, 0 insertions, 49 deletions
diff --git a/external/db_drivers/CMakeLists.txt b/external/db_drivers/CMakeLists.txt
deleted file mode 100644
index 5993ed3a2..000000000
--- a/external/db_drivers/CMakeLists.txt
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright (c) 2014-2015, The Monero Project
-#
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without modification, are
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of source code must retain the above copyright notice, this list of
-# conditions and the following disclaimer.
-#
-# 2. Redistributions in binary form must reproduce the above copyright notice, this list
-# of conditions and the following disclaimer in the documentation and/or other
-# materials provided with the distribution.
-#
-# 3. Neither the name of the copyright holder nor the names of its contributors may be
-# used to endorse or promote products derived from this software without specific
-# prior written permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
-# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
-# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
-# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
-# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-find_package(LMDB)
-
-if(NOT LMDB_LIBRARIES OR STATIC)
- add_subdirectory(liblmdb)
- message(STATUS "lmdb not found, building from src tree")
-
- set(LMDB_STATIC true PARENT_SCOPE)
- set(LMDB_INCLUDE "${CMAKE_CURRENT_SOURCE_DIR}/liblmdb" PARENT_SCOPE)
- set(LMDB_LIBRARY "lmdb" PARENT_SCOPE)
-else()
- message(STATUS "Found liblmdb include (lmdb.h) in ${LMDB_INCLUDE_DIR}")
- if(LMDB_LIBRARIES)
- message(STATUS "Found liblmdb shared library")
- set(LMDB_STATIC false PARENT_SCOPE)
- set(LMDB_INCLUDE ${LMDB_INCLUDE_DIR} PARENT_SCOPE)
- set(LMDB_LIBRARY ${LMDB_LIBRARIES} PARENT_SCOPE)
- set(LMDB_LIBRARY_DIRS "" PARENT_SCOPE)
- else()
- die("Found liblmdb includes, but could not find liblmdb library. Please make sure you have installed liblmdb or liblmdb-dev or the equivalent")
- endif()
-endif()