aboutsummaryrefslogtreecommitdiff
path: root/external/CMakeLists.txt
diff options
context:
space:
mode:
authorJaquee <jaquee.monero@gmail.com>2017-04-02 12:19:25 +0200
committerJaquee <jaquee.monero@gmail.com>2017-04-03 18:38:50 +0200
commitf5bd346573aacba601c948038e39aed24c8c069e (patch)
tree7cc11ce2bb2195ef4d11c54b34f20918e3fdb455 /external/CMakeLists.txt
parentadd IOS CMAKE toolchain (diff)
downloadmonero-f5bd346573aacba601c948038e39aed24c8c069e.tar.xz
IOS CMAKE build settings
Diffstat (limited to 'external/CMakeLists.txt')
-rw-r--r--external/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
index 3c0c0d68e..7dbb55479 100644
--- a/external/CMakeLists.txt
+++ b/external/CMakeLists.txt
@@ -34,11 +34,12 @@
# We always compile if we are building statically to reduce static dependency issues...
# ...except for FreeBSD, because FreeBSD is a special case that doesn't play well with
# others.
-
-find_package(Miniupnpc QUIET)
+if(NOT IOS)
+ find_package(Miniupnpc QUIET)
+endif()
# If we have the correct shared version and we're not building static, use it
-if(STATIC)
+if(STATIC OR IOS)
set(USE_SHARED_MINIUPNPC false)
elseif(MINIUPNP_FOUND AND MINIUPNPC_VERSION_1_7_OR_HIGHER)
set(USE_SHARED_MINIUPNPC true)