aboutsummaryrefslogtreecommitdiff
path: root/external/CMakeLists.txt
diff options
context:
space:
mode:
authorwarptangent <warptangent@tutanota.com>2016-02-12 12:36:55 -0800
committerwarptangent <warptangent@tutanota.com>2016-02-12 15:02:06 -0800
commit7205210b0f6c3648361a9a0b2c17f1b6e7163ad9 (patch)
treec3a47874f840e46af43f69d69eff65472855fc6e /external/CMakeLists.txt
parentcmake: Fix overly broad use of dynamic link settings (diff)
downloadmonero-7205210b0f6c3648361a9a0b2c17f1b6e7163ad9.tar.xz
cmake: Fix unbound config compile settings
This allows the OpenSSL function checks to compile in unbound's CMake configuration. Otherwise, the functions SHA256() and EVP_sha512() won't be called from libunbound as possible algorithms. They had not been compiling because static OpenSSL libraries were being used, along with lack of -ldl. The static library preference is unnecessary for the checks, so use default suffixes ordering for CMAKE_FIND_LIBRARY_SUFFIXES when building unbound. Related files: configure_checks.cmake external/unbound/validator/val_secalgo.c secalgo_ds_digest(), setup_key_digest()
Diffstat (limited to 'external/CMakeLists.txt')
-rw-r--r--external/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
index d13f67b90..70763caf0 100644
--- a/external/CMakeLists.txt
+++ b/external/CMakeLists.txt
@@ -76,7 +76,11 @@ endif()
find_package(Unbound)
if(NOT UNBOUND_INCLUDE_DIR OR STATIC)
+ # We want unbound config tests to be independent of changes made to this setting.
+ set(CURRENT_CMAKE_FIND_LIBRARY_SUFFIXES ${CMAKE_FIND_LIBRARY_SUFFIXES})
+ set(CMAKE_FIND_LIBRARY_SUFFIXES ${ORIG_CMAKE_FIND_LIBRARY_SUFFIXES})
add_subdirectory(unbound)
+ set(CMAKE_FIND_LIBRARY_SUFFIXES ${CURRENT_CMAKE_FIND_LIBRARY_SUFFIXES})
set(UNBOUND_STATIC true PARENT_SCOPE)
set(UNBOUND_INCLUDE "${CMAKE_CURRENT_SOURCE_DIR}/unbound/libunbound" PARENT_SCOPE)