aboutsummaryrefslogtreecommitdiff
path: root/db_drivers/liblmdb-vl32/CMakeLists.txt
diff options
context:
space:
mode:
authorRiccardo Spagni <ric@spagni.net>2015-03-02 11:55:58 +0200
committerThomas Winget <tewinget@gmail.com>2015-03-17 18:25:28 -0400
commit0e8bbdb0bddd35d7dfbec5941189203d5897bb99 (patch)
tree0188d1df43fb133c5bf96432dac4ee89c16128aa /db_drivers/liblmdb-vl32/CMakeLists.txt
parentRevert "Moved db_drivers/ into external/ for consistency" (diff)
downloadmonero-0e8bbdb0bddd35d7dfbec5941189203d5897bb99.tar.xz
32-bit LMDB, removed check for in-system LMDB as it is consensus-critical
Diffstat (limited to 'db_drivers/liblmdb-vl32/CMakeLists.txt')
-rw-r--r--db_drivers/liblmdb-vl32/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/db_drivers/liblmdb-vl32/CMakeLists.txt b/db_drivers/liblmdb-vl32/CMakeLists.txt
new file mode 100644
index 000000000..62b800135
--- /dev/null
+++ b/db_drivers/liblmdb-vl32/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Copyright (c) 2014-2015, The Monero Project
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without modification, are
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this list of
+# conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice, this list
+# of conditions and the following disclaimer in the documentation and/or other
+# materials provided with the distribution.
+#
+# 3. Neither the name of the copyright holder nor the names of its contributors may be
+# used to endorse or promote products derived from this software without specific
+# prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL
+# THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
+# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+set (lmdb_sources
+mdb.c
+midl.c)
+
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
+
+add_library(lmdb
+ ${lmdb_sources})
+target_link_libraries(lmdb
+ LINK_PRIVATE
+ ${CMAKE_THREAD_LIBS_INIT})