aboutsummaryrefslogtreecommitdiff
path: root/contrib/epee/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJeffrey <jeffryan@tamu.edu>2022-03-07 19:16:26 -0600
committerJeffrey <jeffryan@tamu.edu>2022-04-18 09:55:21 -0500
commit441c86073869c5df55e91c39fd4b331212512022 (patch)
tree18129814dc6b2bd30567c758623f3d60b6e5093d /contrib/epee/src/CMakeLists.txt
parentAdd Include statements (diff)
downloadmonero-441c86073869c5df55e91c39fd4b331212512022.tar.xz
Merge functionality of misc_os_dependent into time_helper.h
Actions: 1. Remove unused functions from misc_os_dependent.h 2. Move three remaining functions, get_gmt_time, get_ns_count, and get_tick_count into time_helper.h 3. Remove unused functions from time_helper.h 4. Refactor get_ns_count and get_internet_time_str and get_time_interval_string 5. Remove/add includes as needed Relevant commits on the old PR: a9fbe52b02ffab451e90c977459fea4642731cd1 9a59b131c4ed1be8afe238fff3780fe203c65a46 7fa9e2817df9b9ef3f0290f7f86357939829e588
Diffstat (limited to 'contrib/epee/src/CMakeLists.txt')
-rw-r--r--contrib/epee/src/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/contrib/epee/src/CMakeLists.txt b/contrib/epee/src/CMakeLists.txt
index 13d8154f3..808b9f09e 100644
--- a/contrib/epee/src/CMakeLists.txt
+++ b/contrib/epee/src/CMakeLists.txt
@@ -35,7 +35,6 @@ monero_add_library(epee byte_slice.cpp byte_stream.cpp hex.cpp abstract_http_cli
wipeable_string.cpp levin_base.cpp memwipe.c connection_basic.cpp network_throttle.cpp network_throttle-detail.cpp mlocker.cpp buffer.cpp net_ssl.cpp
int-util.cpp portable_storage.cpp
misc_language.cpp
- misc_os_dependent.cpp
file_io_utils.cpp
net_parse_helpers.cpp
http_base.cpp