aboutsummaryrefslogtreecommitdiff
path: root/contrib/epee/src/CMakeLists.txt
diff options
context:
space:
mode:
authormoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-11-29 19:30:06 +0000
committermoneromooo-monero <moneromooo-monero@users.noreply.github.com>2017-12-16 23:28:43 +0000
commitbb89ae8b2058d98a764f24e17e6c58089dd548f0 (patch)
tree345e5fba3b63920cb4b06d3d2553f580932684d9 /contrib/epee/src/CMakeLists.txt
parentcryptonote_core does not depend on p2p anymore (diff)
downloadmonero-bb89ae8b2058d98a764f24e17e6c58089dd548f0.tar.xz
move connection_basic and network_throttle from src/p2p to epee
These even had the epee namespace. This fixes some ugly circular dependencies.
Diffstat (limited to 'contrib/epee/src/CMakeLists.txt')
-rw-r--r--contrib/epee/src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/contrib/epee/src/CMakeLists.txt b/contrib/epee/src/CMakeLists.txt
index 5cd6d7813..b6967e8fc 100644
--- a/contrib/epee/src/CMakeLists.txt
+++ b/contrib/epee/src/CMakeLists.txt
@@ -26,7 +26,8 @@
# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-add_library(epee STATIC hex.cpp http_auth.cpp mlog.cpp net_utils_base.cpp string_tools.cpp wipeable_string.cpp)
+add_library(epee STATIC hex.cpp http_auth.cpp mlog.cpp net_utils_base.cpp string_tools.cpp wipeable_string.cpp
+ connection_basic.cpp network_throttle.cpp network_throttle-detail.cpp)
if (USE_READLINE AND GNU_READLINE_FOUND)
add_library(epee_readline STATIC readline_buffer.cpp)
endif()