aboutsummaryrefslogtreecommitdiff
path: root/contrib/epee/src/CMakeLists.txt
diff options
context:
space:
mode:
authormj-xmr <mjxmr@protonmail.com>2021-02-25 14:00:43 +0100
committermj-xmr <mjxmr@protonmail.com>2021-02-25 20:16:02 +0100
commit240d382db4a61db6c677e8c51634b937ccbf56a7 (patch)
tree60d7effc5b3e56bef03280773ea36c9f472e9192 /contrib/epee/src/CMakeLists.txt
parentMerge pull request #7381 (diff)
downloadmonero-240d382db4a61db6c677e8c51634b937ccbf56a7.tar.xz
Epee: add headers to project files (via glob), to be able to search for them easily.
Use case: IDEs
Diffstat (limited to 'contrib/epee/src/CMakeLists.txt')
-rw-r--r--contrib/epee/src/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/contrib/epee/src/CMakeLists.txt b/contrib/epee/src/CMakeLists.txt
index 641d4718e..881ae5746 100644
--- a/contrib/epee/src/CMakeLists.txt
+++ b/contrib/epee/src/CMakeLists.txt
@@ -26,11 +26,20 @@
# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
# THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+set(EPEE_INCLUDE_DIR_BASE "${CMAKE_CURRENT_SOURCE_DIR}/../include")
+
+# Adding headers to the file list, to be able to search for them in IDEs.
+file(GLOB EPEE_HEADERS_PUBLIC
+ "${EPEE_INCLUDE_DIR_BASE}/*.h*" # h* will include hpps as well.
+ "${EPEE_INCLUDE_DIR_BASE}/**/*.h*" # Any number of subdirs will be included.
+)
add_library(epee STATIC byte_slice.cpp byte_stream.cpp hex.cpp abstract_http_client.cpp http_auth.cpp mlog.cpp net_helper.cpp net_utils_base.cpp string_tools.cpp
wipeable_string.cpp levin_base.cpp memwipe.c connection_basic.cpp network_throttle.cpp network_throttle-detail.cpp mlocker.cpp buffer.cpp net_ssl.cpp
int-util.cpp portable_storage.cpp
misc_language.cpp
+
+ ${EPEE_HEADERS_PUBLIC}
)
if (USE_READLINE AND (GNU_READLINE_FOUND OR (DEPENDS AND NOT MINGW)))
@@ -74,5 +83,5 @@ if (USE_READLINE AND (GNU_READLINE_FOUND OR (DEPENDS AND NOT MINGW)))
${GNU_READLINE_LIBRARY})
endif()
-target_include_directories(epee PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}/../include")
+target_include_directories(epee PUBLIC "${EPEE_INCLUDE_DIR_BASE}")