aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/unwind.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-03-20 00:33:49 +0100
committerTheCharlatan <seb.kung@gmail.com>2018-09-10 22:05:36 +0200
commit56b6e41ea7b7c17b513c24797d234e5cf9df8fa2 (patch)
tree7a319632b4178438e2578b22c37ad973e83994ad /contrib/depends/packages/unwind.mk
parentDisable stack unwinding for mingw32 depends build. (diff)
downloadmonero-56b6e41ea7b7c17b513c24797d234e5cf9df8fa2.tar.xz
Add support for apple and arm building
Add pcsc-lite to linux builds Fixup windows icu4c linking with depends, the static libraries have an 's' appended to them Compiling depends arm-linux-gnueabihf will allow you to compile armv6zk monero binaries
Diffstat (limited to 'contrib/depends/packages/unwind.mk')
-rw-r--r--contrib/depends/packages/unwind.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/contrib/depends/packages/unwind.mk b/contrib/depends/packages/unwind.mk
index 06e142115..e1bcb35b2 100644
--- a/contrib/depends/packages/unwind.mk
+++ b/contrib/depends/packages/unwind.mk
@@ -5,7 +5,9 @@ $(package)_file_name=lib$(package)-$($(package)_version).tar.gz
$(package)_sha256_hash=1de38ffbdc88bd694d10081865871cd2bfbb02ad8ef9e1606aee18d65532b992
define $(package)_config_cmds
- $($(package)_autoconf) --disable-shared --enable-static
+ cp -f $(BASEDIR)/config.guess config/config.guess &&\
+ cp -f $(BASEDIR)/config.sub config/config.sub &&\
+ $($(package)_autoconf) --disable-shared --enable-static
endef
define $(package)_build_cmds