aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/sodium-darwin.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-09-25 19:54:41 +0000
committerTheCharlatan <seb.kung@gmail.com>2018-09-25 23:05:16 +0200
commit6a78140863cbfc11dd4388901c913717f8ca4d17 (patch)
treeee55841767107539fde68c2fe58b089603c785a2 /contrib/depends/packages/sodium-darwin.mk
parentMerge pull request #4435 (diff)
downloadmonero-6a78140863cbfc11dd4388901c913717f8ca4d17.tar.xz
Make depends use self built clang for darwin
The configure script in hidapi and libsodium tried to find clang in /usr/bin, even though the correct prefix was passed in. This sets the correct CC flag. This was previously undetected, because clang and the sdk where installed in the global environment. This also fixes a subsequent error, where IOKIT and CoreFoundation are not found, again for the reason stated above.
Diffstat (limited to '')
-rw-r--r--contrib/depends/packages/sodium-darwin.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/contrib/depends/packages/sodium-darwin.mk b/contrib/depends/packages/sodium-darwin.mk
index 796bead16..59c6d1ec6 100644
--- a/contrib/depends/packages/sodium-darwin.mk
+++ b/contrib/depends/packages/sodium-darwin.mk
@@ -5,13 +5,14 @@ $(package)_file_name=libsodium-$($(package)_version).tar.gz
$(package)_sha256_hash=fb6a9e879a2f674592e4328c5d9f79f082405ee4bb05cb6e679b90afe9e178f4
define $(package)_set_vars
+$(package)_build_opts_darwin=OS=Darwin LIBTOOL="$($(package)_libtool)"
$(package)_config_opts=--enable-static
$(package)_config_opts+=--prefix=$(host_prefix)
endef
define $(package)_config_cmds
./autogen.sh &&\
- $($(package)_autoconf) $($(package)_config_opts) RANLIB="$(host_prefix)/native/bin/x86_64-apple-darwin11-ranlib" AR="$(host_prefix)/native/bin/x86_64-apple-darwin11-ar"
+ $($(package)_autoconf) $($(package)_config_opts) RANLIB="$(host_prefix)/native/bin/x86_64-apple-darwin11-ranlib" AR="$(host_prefix)/native/bin/x86_64-apple-darwin11-ar" CC="$(host_prefix)/native/bin/$($(package)_cc)"
endef
define $(package)_build_cmds