aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/readline.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2019-01-29 16:18:47 +0100
committerTheCharlatan <seb.kung@gmail.com>2019-02-23 15:34:59 +0100
commitf0fc4064a0c8d55d118cbef47a41b23cf998e194 (patch)
tree753b60c4233666006605a429a69839c3f4940d7b /contrib/depends/packages/readline.mk
parentMerge pull request #5062 (diff)
downloadmonero-f0fc4064a0c8d55d118cbef47a41b23cf998e194.tar.xz
Various speedups to depends and Travis
Further speedups to icu compilation, it is faster to run the pre-generated configure scripts. Ensure that the native protobuf installation only generates the required libraries and binaries. Disable qt compilation when running travis on windows. Qt is used for lrelease, the travis recipe instead usese the a local installation of lrelease. Remove various packages and options from the travis recipe. Update Readline to version 8.0. The previously used url 404'd sometimes, use the official gnu ftp server instead. Remove unused cmake config.
Diffstat (limited to 'contrib/depends/packages/readline.mk')
-rw-r--r--contrib/depends/packages/readline.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/contrib/depends/packages/readline.mk b/contrib/depends/packages/readline.mk
index 826c1029e..afefc7f07 100644
--- a/contrib/depends/packages/readline.mk
+++ b/contrib/depends/packages/readline.mk
@@ -1,9 +1,8 @@
package=readline
-$(package)_version=6.3
-$(package)_download_path=ftp://ftp.cwru.edu/pub/bash/
+$(package)_version=8.0
+$(package)_download_path=https://ftp.gnu.org/gnu/readline
$(package)_file_name=$(package)-$($(package)_version).tar.gz
-$(package)_sha256_hash=56ba6071b9462f980c5a72ab0023893b65ba6debb4eeb475d7a563dc65cafd43
-$(package)_patches=readline-1.patch
+$(package)_sha256_hash=e339f51971478d369f8a053a330a190781acb9864cf4c541060f12078948e461
define $(package)_set_vars
$(package)_build_opts=CC="$($(package)_cc)"
@@ -15,7 +14,6 @@ define $(package)_set_vars
endef
define $(package)_config_cmds
- patch -p1 < $($(package)_patch_dir)/readline-1.patch &&\
export bash_cv_have_mbstate_t=yes &&\
export bash_cv_wcwidth_broken=yes &&\
./configure $($(package)_config_opts)
@@ -29,5 +27,3 @@ define $(package)_stage_cmds
$(MAKE) DESTDIR=$($(package)_staging_dir) install
endef
-define $(package)_postprocess_cmds
-endef