aboutsummaryrefslogtreecommitdiff
path: root/contrib/depends/packages/qt.mk
diff options
context:
space:
mode:
authorTheCharlatan <seb.kung@gmail.com>2018-12-08 00:16:27 +0100
committerTheCharlatan <seb.kung@gmail.com>2019-01-17 13:23:24 +0100
commitb4433abc6452de45ec6f2b97971aeb0d5ee2bd7c (patch)
tree4a3330ff6bb4da4ad906cbd53403c2196c627879 /contrib/depends/packages/qt.mk
parentMerge pull request #5043 (diff)
downloadmonero-b4433abc6452de45ec6f2b97971aeb0d5ee2bd7c.tar.xz
Optimize the depends builds for faster compilation
This includes more fine grained configure options and skipping the openssl and zlib dependencies when compiling qt. The zlib and libevent packages are removed.
Diffstat (limited to '')
-rw-r--r--contrib/depends/packages/qt.mk10
1 files changed, 4 insertions, 6 deletions
diff --git a/contrib/depends/packages/qt.mk b/contrib/depends/packages/qt.mk
index bca2926cb..6a6f0e0f7 100644
--- a/contrib/depends/packages/qt.mk
+++ b/contrib/depends/packages/qt.mk
@@ -4,7 +4,6 @@ $(package)_download_path=https://download.qt.io/archive/qt/5.7/5.7.1/submodules
$(package)_suffix=opensource-src-$($(package)_version).tar.gz
$(package)_file_name=qtbase-$($(package)_suffix)
$(package)_sha256_hash=95f83e532d23b3ddbde7973f380ecae1bac13230340557276f75f2e37984e410
-$(package)_dependencies=openssl zlib
$(package)_build_subdir=qtbase
$(package)_qt_libs=corelib
$(package)_patches=pidlist_absolute.patch fix_qt_pkgconfig.patch qfixed-coretext.patch
@@ -62,14 +61,14 @@ $(package)_config_opts += -no-xrender
$(package)_config_opts += -nomake examples
$(package)_config_opts += -nomake tests
$(package)_config_opts += -opensource
-$(package)_config_opts += -openssl-linked
+$(package)_config_opts += -no-openssl
$(package)_config_opts += -optimized-qmake
$(package)_config_opts += -pch
$(package)_config_opts += -pkg-config
-$(package)_config_opts += -qt-libpng
-$(package)_config_opts += -qt-libjpeg
+$(package)_config_opts += -no-libpng
+$(package)_config_opts += -no-libjpeg
$(package)_config_opts += -qt-pcre
-$(package)_config_opts += -system-zlib
+$(package)_config_opts += -no-zlib
$(package)_config_opts += -reduce-exports
$(package)_config_opts += -static
$(package)_config_opts += -silent
@@ -124,7 +123,6 @@ define $(package)_config_cmds
export PKG_CONFIG_LIBDIR=$(host_prefix)/lib/pkgconfig && \
export PKG_CONFIG_PATH=$(host_prefix)/share/pkgconfig && \
./configure $($(package)_config_opts) && \
- echo "host_build: QT_CONFIG ~= s/system-zlib/zlib" >> mkspecs/qconfig.pri && \
echo "CONFIG += force_bootstrap" >> mkspecs/qconfig.pri && \
$(MAKE) sub-src-clean && \
cd ../qttranslations && ../qtbase/bin/qmake qttranslations.pro -o Makefile && \